Tài liệu miễn phí phục vụ học tập nghiên cứu
Tìm nhiều : Tiếng anh, Photoshop , Lập trình

Tạo đường hầm và định tuyến trên nền IPv6

  • Loại tài liệu : .doc
  • Dung lượng:0.75 M
  • Lần download: 43 lần
  • Chi phí: Miễn phí, download free

Tạo đường hầm và định tuyến trên nền IPv6

Loại tài liệu : .doc Dung lượng:0.75 M Lần download: 43 lần Chi phí: Miễn phí, download free

Tạo đường hầm và định tuyến trên nền IPv6 -

Tải tài liệu Tạo đường hầm và định tuyến trên nền IPv6 miễn phí ,tại Thư viện tài liệu miễn phí www.thuvienmienphi.com bạn có thể tải nhiều tài liệu, thư viện hoàn toàn miễn phí,bạn có thể chia sẽ tài liệu Tạo đường hầm và định tuyến trên nền IPv6 của bạn cho mọi người cùng nghiên cứu học tập tại đây .DOC: là dạng tài liệu đọc bằng thư viện Microsoft Office,PDF là dạng file đọc bằng phần mềm Adobe - Adobe Reader Một số tài liệu tải về mất font không xem được thì do máy tính bạn không hỗ trợ font củ, bạn tải font các font vntime củ về cài sẽ xem được.

Lab 5.2: Tạo đường hầm và định tuyến trên nền IPv6.

Sơ đồ

 

     Hình 5.2a.

 

    Hình 5.2b.

 

Yêu cầu

-          Đặt địa chỉ IPv6 và IPv4 như hình 5.2a. Thực hiện định tuyến IPv4 đảm bảo mọi địa chỉ IPv4 thấy nhau.

-          Thực hiện tạo đường hầm IPv6 – IPv4 – IPv6 đảm bảo miền IPv6 được liên tục như hình 5.2b.

-          Chạy định tuyến trên nền IPv6 như mô tả trên hình 5.2b, đảm bảo mọi địa chỉ IPv6 thấy nhau.

Thực hiện

Bước 1: Đặt các địa chỉ IPv6 và IPv4 như hình 5.2a.

Trên router R1:

R1(config)#interface FastEthernet0/1

R1(config-if)#ipv6 address 2000:12::1/64

R1(config)#interface Loopback0

R1(config-if)# ipv6 address 2000:1::1/64


Trên router R2:

R2(config)#interface FastEthernet0/0

R2(config-if)#ipv6 address 2000:12::2/64

R2(config)#interface Loopback0

R2(config-if)#ipv6 address 2000:2::1/64

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 192.168.23.2 255.255.255.0

Trên router R3:

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 192.168.23.3 255.255.255.0

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 192.168.34.3 255.255.255.0

Trên router R4:

R4(config)#interface FastEthernet0/0

R4(config-if)#ip address 192.168.34.4 255.255.255.0

R4(config)#interface FastEthernet0/1

R4(config-if)#ipv6 address 2000:45::4/64

R4(config)#interface Loopback0

R4(config-if)#ipv6 address 2000:4::1/64

Trên router R5:

R5(config)#interface FastEthernet0/0

R5(config-if)#ipv6 address 2000:45::5/64

R5(config)#interface Loopback0

R5(config-if)#ipv6 address 2000:5::1/64

 

Bước 2: Chạy định tuyến, đảm bảo mọi địa chỉ IPv4 thấy nhau, đặc biệt là hai địa chỉ 192.168.23.2 và 192.168.34.4 vì đây là hai địa chỉ sẽ dùng để thiết lập đường hầm IPv6 xuyên qua đám mây IPv4. Với sơ đồ trên hình 5.2a, chỉ cần thực hiện hai default – route từ R2 và R4 chỉ đến R3 là đáp ứng được yêu cầu thông suốt định tuyến trên miền IPv4.

Trên router R2 và R4 thực hiện cấu hình các default – route chỉ về R3:

R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.3

R4(config)#ip route 0.0.0.0 0.0.0.0 192.168.34.3

Thực hiện ping kiểm tra giữa hai địa chỉ 192.168.23.2 và 192.168.34.4:

 

Từ R2:

R2#ping 192.168.34.4 source 192.168.23.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.34.4, timeout is 2 seconds:

Packet sent with a source address of 192.168.23.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 72/108/148 ms

R2#

Từ R4:

R4#ping 192.168.23.2 source 192.168.34.4

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.23.2, timeout is 2 seconds:

Packet sent with a source address of 192.168.34.4

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 52/92/112 ms

R4#

Bước 3: Thực hiện tạo đường hầm để nối liền hai miền IPv6. Đặt địa chỉ IPv6 hai đầu đường hầm như mô tả trên sơ đồ hình 5.2b.

Trên R2:

R2(config)#interface Tunnel0

R2(config-if)#ipv6 address 2000:24::2/64

R2(config-if)#tunnel source 192.168.23.2

R2(config-if)#tunnel destination 192.168.34.4

R2(config-if)#tunnel mode ipv6ip

Trên R4:

R4(config)#interface Tunnel0

R4(config-if)#ipv6 address 2000:24::4/64

R4(config-if)#tunnel source 192.168.34.4

R4(config-if)#tunnel destination 192.168.23.2

R4(config-if)#tunnel mode ipv6ip

 

Kiểm tra rằng đường hầm đã được tạo thành công (các đường hầm đều  ở trạng thái “up/up”):

 

 

Trên R2:

R2#show ipv6 interface brief

FastEthernet0/0            [up/up]

    FE80::C001:EFF:FE20:0

    2000:12::2

FastEthernet0/1            [up/up]

Loopback0                  [up/up]

    FE80::C001:EFF:FE20:0

    2000:2::1

Tunnel0                    [up/up]

    FE80::C0A8:1702

    2000:24::2

Trên R4:

R4#show ipv6 interface brief

FastEthernet0/0            [up/up]

FastEthernet0/1            [up/up]

    FE80::C003:EFF:FE20:1

    2000:45::4

Loopback0                  [up/up]

    FE80::C003:EFF:FE20:0

    2000:4::1

Tunnel0                    [up/up]

    FE80::C0A8:2204

    2000:24::4

Bắt đầu từ đây ta chuyển qua làm việc với sơ đồ mạng thuần túy IPv6 được mô tả trong hình 5.2b.

Bước 4: Chạy các giao thức định tuyến IPv6 trên các router theo yêu cầu được mô tả trên hình 5.2b.

Trên tất cả các router bật định tuyến IPv6:

R(config)#ipv6 unicast-routing

Trên R1, chạy giao thức RIPng:

R1(config)#ipv6 router rip R1

R1(config-rtr)#exit

R1(config)#interface FastEthernet0/1

R1(config-if)#ipv6 rip R1 enable

R1(config)#interface Loopback0

R1(config-if)#ipv6 rip R1 enable

 

Trên R2, chạy các giao thức RIPng và OSPFv3:

R2(config)#ipv6 router rip R2

R2(config-rtr)#exit

R2(config)#interface FastEthernet0/0

R2(config-if)#ipv6 rip R2 enable

R2(config)#ipv6 router ospf 1

R2(config-rtr)# router-id 2.2.2.2

R2(config-rtr)#exit

R2(config)#interface tunnel 0

R2(config-if)#ipv6 ospf 1 area 1

R2(config-if)#interface loopback 0

R2(config-if)#ipv6 ospf 1 area 2

Trên R4, chạy giao thức OSPFv3:

R4(config)#ipv6 router ospf 1

R4(config-rtr)# router-id 4.4.4.4

R4(config-rtr)#exit

R4(config)#interface tunnel 0

R4(config-if)#ipv6 ospf 1 area 1

R4(config-if)#interface loopback 0

R4(config-if)#ipv6 ospf 1 area 1

R4(config-if)#interface fastEthernet 0/1

R4(config-if)#ipv6 ospf 1 area 0

Trên R5, chạy giao thức OSPFv3:

R5(config)#ipv6 router ospf 1

R5(config-rtr)#router-id 5.5.5.5

R5(config-rtr)#exit

R5(config)#interface FastEthernet0/0

R5(config-if)#ipv6 ospf 1 area 0

R5(config-if)#interface loopback 0

R5(config-if)#ipv6 ospf 1 area 0

Bước 5: Ta thấy vùng 2 của miền OSPF không có kết nối trực tiếp về vùng 0. Điều này sẽ làm cho loopback 0 của R2 không thể đi tới được. Để khắc phục, ta thực hiện cấu hình một đường virtual – link (đường liên kết ảo) nối vùng 2 với vùng 0. Việc cấu hình virtual – link được thực hiện trên các router R2 và R4.

Trên R2:

R2(config)#ipv6 router ospf 1

R2(config-rtr)#area 1 virtual-link 4.4.4.4

 

 

Trên R4:

R4(config)#ipv6 router ospf 1

R4(config-rtr)#area 1 virtual-link 2.2.2.2

Kiểm tra lại rằng đường virtual – link đã đi vào hoạt động (up).

Trên R2:

R2#show ipv6 ospf virtual-links

Virtual Link OSPFv3_VL0 to router 4.4.4.4 is up

  Interface ID 10, IPv6 address 2000:4::1

  Run as demand circuit

  DoNotAge LSA allowed.

  Transit area 1, via interface Tunnel0, Cost of using 11111

  Transmit Delay is 1 sec, State POINT_TO_POINT,

  Timer intervals configured, Hello 10,Dead 40,Wait 40, Retransmit 5

    Adjacency State FULL (Hello suppressed)

    Index 1/1/2, retransmission queue length 0, number of retransmission 2

    First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)

    Last retransmission scan length is 1, maximum is 1

    Last retransmission scan time is 0 msec, maximum is 0 msec

Trên R4:

R4#show ipv6 ospf virtual-links

Virtual Link OSPFv3_VL1 to router 2.2.2.2 is up

  Interface ID 12, IPv6 address 2000:24::2

  Run as demand circuit

  DoNotAge LSA allowed.

  Transit area 1, via interface Tunnel0, Cost of using 11111

  Transmit Delay is 1 sec, State POINT_TO_POINT,

1

 

 

DOWNLOAD TÀI LIỆU
Bấm nút LIKE +1 để cảm ơn
  
     
SAU ĐÓ BẤM
Download miễn phí

HỎI ĐÁP LIÊN QUAN

Tài liệu tương tự

Nội quy


website trong giai đoạn phát triển và hoạt động thử nghiệm, tài liệu đăng tải được sưu tầm trên internet tu cac website nhu tailieu.vn, 123doc...nham muc dich chia se kien thuc hoc tap, nếu tai lieu nao thuộc bản quyền hoặc phi phạm pháp luật chúng tôi sẽ gở bỏ theo yêu cầu Tài liệu học tập miễn phí